2016年5月29日 星期日

在 Ubuntu 16.04 上面使用自然人憑證報稅

發現完全可以依照兩年前寫過的在 Ubuntu 14.04 上面使用自然人憑證報稅的步驟,現在不管是 i386 的或是 amd64 的都可以運作。

只是我不明白為什麼自然人憑證用戶端元件安裝 (HiPKIClient) 上面完全沒有提到有 amd64 的版本可以使用。

這樣一來我就不用設法去生一個 i386 的環境來使用。

另外今年大家都會遇到的問題是 HiPKIClient 沒有合法簽章,因為現在的 Firefox 預設上都強制要求 extension/plugin 要有合法簽章才能夠使用,不然的話就要手動停用強制簽署的功能。

「你可以在 Firefox 設定編輯器(about:config 頁面)將 xpinstall.signatures.required 修改成 false 來暫時停用強制簽署的功能。」

還有要注意安裝 EZ-100PU 讀卡機的驅動程式有沒有符合系統的版本,通常使用指令

uname -i
就可以知道當下的系統是 i386 還是 x86_64 (aka amd64) 了。

$ unzip -l 201511920271676073.zip 
Archive:  201511920271676073.zip
  Length      Date    Time    Name
---------  ---------- -----   ----
        0  2011-08-10 15:04   EZUSB_Linux/
    69340  2011-08-10 14:54   EZUSB_Linux/EZUSB_Linux_x86_64_v1.5.3.zip (amd64)
    58687  2011-08-10 14:54   EZUSB_Linux/EZUSB_Linux_x86_v1.5.3.zip    (i386)
       58  2008-04-09 13:12   Archive created by free jZip.url
---------                     -------
   128085                     4 files

最後就是要安裝 Java 7 才能夠正常使用,但是 Oracle 已經不再維護 Java 7 了,Oracle 目前建議使用的是 Java 8,但是 Java 8 完全無法在 Ubuntu 16.04 (amd64) 上面的 Firefox 46.0.1 正常使用,不曉得國稅局何時才會請中華電信還是關貿網路來解決這個問題。

出社會工作後都是用 Linux 系統在報稅,可是十幾年過去了,還是覺得政府做得很糟糕。:-(

張貼留言